Pré-requis de la Distribution Entreprise

Vous avez une question au sujet de votre configuration ou des problèmes potentiels de compatibilité avec la Distribution Entreprise ?

Pré-requis serveur

Utilisant la technologie PHP, notre serveur fonctionne sur presque tous les serveurs web standards. Quelques exigences de base doivent être respectées pour vous assurer que votre Pydio fonctionnera correctement, et vous assurera le meilleur niveau de support.

  • PHP Version : 5.6 ou supérieure (PHP7 recommandé)
  • Extension PHP requise : IonCube Loader
  • Cache : Extension PHP Apc/ApcU ou serveur additionnel Redis
  • Server OS + WebServer software
     . Linux + Apache ou Linux + Nginx
     . Linux : CentOS, RHEL, Debian, Ubuntu
     . Windows Server 2012 R2 + IIS8
  • Limitation de Windows: à cause de la version PHP de Windows, Pydio risque de ne pas être stable sur 64bits et ne peut pas gérer les fichiers de plus de 2Go sur Windows (sauf en utilisant Pydio Booster).
  • Processeur : cela dépend fortement du load du serveur, de l'utilisation de Pydiosync... Nous recommandons une configuration minimum de 4 vCore ou équivalent / 100 utilisateurs.
  • Mémoire vive : 8Go / 100 Utilisateurs

Il s'agit de pré-requis pour une installation standard de Pydio. Certains plugins optionnels peuvent nécessiter des extensions supplémentaires.

 Contactez nous si vous avez des questions sur des besoins spécifiques.

 

Clients et Navigateurs

Vos utilisateurs peuvent accéder à Pydio via  de multiples appareils et applications. Pour assurer un déploiement facile, nous vous recommandons de vérifier la compatibilité:

  • PydioSync
    - Windows : 7 / 8 / 10 - 64bits /32bits
    - Mac OSX : 10.8, 10.9, 10.10, 10.11
    - Linux (non supporté)
     
  •  Applications mobiles
    - iOS 9 / 10
    - Android 4.4+ 
    - Autres OS : accès via le navigateur web
     
  • Navigateurs pour l'application Web
    - Chrome / Firefox / Safari
    - Internet Explorer 10+ / Edge
     
  • Navigateurs pour le tableau de bord Entreprise
     
    - Chrome / Firefox
    - Internet Explorer 10+ / Edge

Pour plus d'informations sur chaque application, consultez les pages de téléchargement.

Plugins supportés de la Distribution Entreprise

Storage drivers configuration & auth workspace features enterprise plugins other features
Local FileSystem SQL only (no serial) Lucene Indexation Admin Dashboard Disclaimer
FTP / SFTP MySQL / PGSQL Action.powerfs   PHPMailer
S3 Logs in DB All Editors    
Samba   Simple Log, text metadata    
Auto-Mount LDAP / AD exif metadata, git versioning    
  CAS, OTP Meta.watch, comments feed    

 

Créer votre propre Plugin

Vous souhaitez vous connecter à un système d'authentification développé sur-mesure ?

Pydio supportera l’installation de votre Enterprise Distribution. Si vous avez des questions relative de vos besoins spécifiques, contactez nous.