All public share links load as blank pages

Home Forums Troubleshooting Generic Help All public share links load as blank pages

This topic contains 4 replies, has 2 voices, and was last updated by Profile photo of rcthompson rcthompson 1 day, 5 hours ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #113766
    Profile photo of rcthompson
    rcthompson
    Participant

    I have successfully set up an instance of Pydio on my personal web server following the standard instructions, and everything seems to be working well, except for one problem: any public link that I generate just loads a blank page when I try to load it. For example, this link, which should be for a file called “test.odt”: https://mneme.dedyn.io/pydio/public/sharetest

    One possibly related fact is that the Pydio diagnostic info (see below) insists that php output buffering is not disabled, despite the fact that I have literally grepped for every occurrence of “output_buffering” in /etc and set them all to Off.

    Can anyone suggest what might be causing this and how to fix it?

    System info

    $ uname -a
    Linux mneme.dedyn.io 4.8.0-59-generic #64-Ubuntu SMP Thu Jun 29 19:38:34 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
    $ lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 16.10
    Release: 16.10
    Codename: yakkety

    Diagnostic info:

    Client : Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:55.0) Gecko/20100101 Firefox/55.0
    Crypto Extension Detected : OpenSSL
    Command Line Available : Yes
    DOM Enabled : Yes
    Exif Enabled : Yes
    GD Enabled : Yes
    Upload Max Size : 0
    Memory Limit : 128M
    Max execution time : 30
    Safe Mode : 0
    Safe Mode GID : 0
    Xml parser enabled : 1
    Server OS : Linux
    Session Save Path : /var/lib/php/sessions
    Session Save Path Writeable : Yes
    PHP Version : 7.0.15-0ubuntu0.16.10.4
    Locale : en_US.UTF-8
    Directory Separator : /
    PHP Opcode Cache extension loaded : Yes
    PHP INTL extension loaded : Yes
    PHP Output Buffer disabled : No
    PHP File Uploads enabled : Yes
    Magic quotes disabled : Yes
    Upload Tmp Dir Writeable : Yes
    PHP Upload Max Size : 0
    PHP Post Max Size : 0
    Users enabled : Yes
    Guest enabled : No
    Writeable Folders : [<b>cache</b>:true,<br> <b>data</b>:true]
    Zlib Enabled : Yes


    #113768
    Profile photo of tropicalmango
    tropicalmango
    Participant

    Hi,

    First, make sure rewrite module is activated (apache module)

    Second, could you please post the content of .htaccess in the root of Pydio folder if it was modified (the default can be found here: https://github.com/pydio/pydio-core/blob/develop/core/src/.htaccess)


    #113776
    Profile photo of rcthompson
    rcthompson
    Participant

    Apache2 rewrite module is definitely enabled, and the only change I made to .htaccess was to set RewriteBase to /pydio.


    #113797
    Profile photo of tropicalmango
    tropicalmango
    Participant

    Hi,

    Make sure there no “public” folder inside pydio root folder


    #113800
    Profile photo of rcthompson
    rcthompson
    Participant

    There is definitely no folder named “public” in pydio’s root folder:

    $ ls /var/www/mneme.dedyn.io/pydio
    base.conf.php
    cmd.php
    conf
    core
    data
    index.php
    nginx.conf.sample
    phpdoc.dist.xml
    plugins
    proxy.php
    publicLet.inc.php
    robots.txt
    runTests.php
    web.config.sample
    worker.php


Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.