Authentication failed: please verify your login and password

Home Forums Troubleshooting PydioSync Issues Authentication failed: please verify your login and password

Viewing 15 posts - 1 through 15 (of 30 total)
  • Author
    Posts
  • #90081
    #90082
    Profile photo of abolfazl
    Anonymous

    Also i have out commented: SetEnvIf Authorization “(.*)” HTTP_AUTHORIZATION=$1 in the htcaccess


    #90130
    Profile photo of abolfazl
    Anonymous

    Try to remove comment in .htaccess in

    #RewriteCond %{HTTP:Authorization} ^(.*)
    #RewriteRule ^(.*) – [E=HTTP_AUTHORIZATION:%1]


    #90136
    Profile photo of abolfazl
    Anonymous

    I have the same problem.
    i remove comment in .htaccess in

    #RewriteCond %{HTTP:Authorization} ^(.*)
    #RewriteRule ^(.*) – [E=HTTP_AUTHORIZATION:%1]

    and nothing.


    #90137
    Profile photo of abolfazl
    Anonymous

    For testing API in Pydio v6
    uncomment “die(…)” in runTests.php
    then browse this file
    http://address/runTests.php?api=true

    login to see error message


    #90192
    Profile photo of Charles
    Charles
    Keymaster

    To all of you: did you maybe change the “Transmit Clear Pass” option in the Authentication settings? If so, make sure it’s set to Yes.
    -c


    Charles, Pydio author - doing my best to help !
    If you like the software or want to say thanks, pay by a tweet, mention #pydio or follow us

    #90270
    Profile photo of abolfazl
    Anonymous

    Im getting this error in that test, i tried to switch transmit clear pass on and off but get the same result:

    Getting authentication token with user credentials

    Warning: file_get_contents(http://…@myodmain/api/pydio/keystore_generate_auth_token/php_client) [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.1 401 Unauthorized in /home/www/mydomain/runTests.php on line 61
    Data returned is not JSON! There is something wrong with the API. Exiting.NULL


    #90278
    Profile photo of abolfazl
    Anonymous

    Seriously think the features you provide here to edit the files are not correct and really do not provide adequate support or have the pydiosync developed 100% for MAC.

    The best option is to migrate to another content management system, since this has just miss me lose alot time.


    • This reply was modified 6 years, 4 months ago by Profile photo of abolfazl .
    #90288
    Profile photo of Charles
    Charles
    Keymaster

    Ok chefoco, no problem. Working for most people, but when you’re one of them, can be indeed irritating… That’s why we’are working on expanding the docs, to help.
    Gurmukh, can you switch your server to debug mode and see if there are any errors?
    -c


    Charles, Pydio author - doing my best to help !
    If you like the software or want to say thanks, pay by a tweet, mention #pydio or follow us

    #90307
    Profile photo of abolfazl
    Anonymous

    Show errors is enabled on the server, if you mean debug mode as in i directly host the server mig self and can edit it then it’s a no :( If you mean Debug mode in Pydio i enabled:

    // DEBUG OPTIONS
    define(“AJXP_CLIENT_DEBUG” , true);
    define(“AJXP_SERVER_DEBUG” , true);
    define(“AJXP_SKIP_CACHE” , true);

    nothing shows and API does the same, and it seems now i can’t either login to the account after i enabled or disabled Transmit Clear pass, think thats done it…


    #90308
    Profile photo of abolfazl
    Anonymous

    Did a fresh install in a folder to test, and there i get this:

    Getting authentication token with user credentials

    Warning: file_get_contents(http://…@mydomain/api/pydio/keystore_generate_auth_token/php_client): failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in /home/www/mydomain/runTests.php on line 61
    Data returned is not JSON! There is something wrong with the API. Exiting.NULL

    I know it works with this provider, as i know Tran as made it work… 😀 I’m just curious why im having all these challenges.


    #90318
    Profile photo of Charles
    Charles
    Keymaster

    Did you update the runTest.php to the latest git version as indicated in the “Checking Sync” article? (see admin docs)
    -c


    Charles, Pydio author - doing my best to help !
    If you like the software or want to say thanks, pay by a tweet, mention #pydio or follow us

    #91391
    Profile photo of abolfazl
    Anonymous

    Hi,

    I do not want to steal this thread, but I have the same problem with a fresh installed server.

    The sync with the linux client is working (more or less, see my other article), so I think the preconditions are fullfiled on server side.

    But I can not connect with the windows client. I get the error
    “Error while trying to connect to https://myserver/path :
    Authentication failed: please verify your login and password”

    If you prefer this in a different thread please let me know…


    #91741
    Profile photo of abolfazl
    Anonymous

    Hi, we have the latest version Pydio 6.0.6.
    I tryed the Pydio Sync (Win Version) and i have the same problem with login and we got following error message:
    “Authentication failed: please verify your login and password” Same with Https

    I tryed to remove in .htaccess
    #RewriteCond %{HTTP:Authorization} ^(.*)
    #RewriteRule ^(.*) – [E=HTTP_AUTHORIZATION:%1]
    Nothing.

    After that in uncomment “die(…)” in runTests.php
    then i browsed this file
    http://address/runTests.php?api=true
    And got following error message:

    “Getting authentication token with user credentials
    Data returned is not JSON! There is something wrong with the API. Exiting.NULL”

    Any Idea?
    Thanks


    #91775
    Profile photo of Charles
    Charles
    Keymaster

    Hi guys, what your servers?
    Also, are you using https with a self-signed or a-like certificate?
    -c


    Charles, Pydio author - doing my best to help !
    If you like the software or want to say thanks, pay by a tweet, mention #pydio or follow us

Viewing 15 posts - 1 through 15 (of 30 total)

The forum ‘PydioSync Issues’ is closed to new topics and replies.