Can't delete/move/rename folders in S3 workspace

Home Forums Troubleshooting Plugins & Bridges Can't delete/move/rename folders in S3 workspace

Tagged: 

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #102657
    Profile photo of abolfazl
    Anonymous

    Attempting to delete/move/rename a folder that is part of a S3 workspace results in

    The specified key does not exist.

    I understand why this happens at the S3 level, because there are no folders in S3, simply delimiters in a object name, but something appears to be wrong with deleting at the ‘folder’ level. Is there any way around this? This is potentially a showstopper for our users.

    Everything else appears to work fine in the workspace (within the constraints of this workspace type).


    #103923
    Profile photo of abolfazl
    Anonymous

    This issue is also preventing users from creating folders over webdav, because Windows creates a folder as “New Folder” then a rename operation fails because it can’t find the specified key. It seems like Pydio isn’t properly handling folders with S3 at all. Any thoughts on this at all? I really need to resolve this so I can push forward with rolling this out across our Org.


    #103927
    Profile photo of abolfazl
    Anonymous

    With the newest version of Pydio, it now says internal server error on rename operation and tells me to check the log, but the apache2 error log does not get any message generated from that action.

    A delete operation in the newest version generates this error:

    message=require_once(aws-v2.phar): failed to open stream: No such file or directory


    #103928
    Profile photo of abolfazl
    Anonymous

    I resolved both the new errors by copying the latest AWS SDK for PHP .phar file to the appropriate directory and naming it aws-v2-.phar but I am back to the specified key does not exist.


    #103990
    Profile photo of abolfazl
    Anonymous

    Hello,

    Can you please let me know the following ?

    – the version of the aws sdk phar you’ve installed ? Is that the same version you’ve set as aws-v2.phar ? (You can find the list here https://github.com/aws/aws-sdk-php/releases)
    – can you send me the configuration you’ve made of the s3 workspace ? (you can blank the keys).

    I’ve tried reproducing it but I can’t. As you mentioned, S# doesn’t allow renaming of folders, but what pydio does to go around that limitation is copying the object to a new folder and deleting the empty old one after it’s finished. So there’s technically no reason why the renaming of new folders wouldn’t work through webdav.

    Let me know,
    Thanks,
    G


    #103991
    Profile photo of abolfazl
    Anonymous

    Version 3.18.36 is what I downloaded and renamed aws-v2.phar, I dropped it in the same folder as the other .phar file, but did not overwrite the old one.

    To be clear renaming, deleting, or moving doesn’t work for folders at all, webdav or web gui. I did look at the PHP file that generated the error for the missing aws-v2.phar and noticed it does specifically look for directories and cp then delete them. Which totally makes sense.

    General Options:
    Label: Accounting
    Description: Accounting shared folder.
    Default Rights: Read and Write
    alias: accounting-1
    Group Path: /
    Webdav box is unchecked

    Driver: S3 (Amazon Web Service)
    Location: US Standard
    Container: bucket/FOLDER/SUB (I don’t think the exact name matters here)
    All other options are default under Driver

    Additional Features
    MetaStore S3
    File Hasher
    Watch Metadata
    Lucene Search Engine

    I have tried other combinations of Additional Features, using no additional features at all.. everything seems to result in the same error.


    #103997
    Profile photo of abolfazl
    Anonymous

    I may abandon the S3 driver, considering a fresh install has the same issue. I’m really not sure what I am doing wrong. Alternatively S3FS with the local FS driver works perfectly fine and meets my needs.


    #104748
    Profile photo of abolfazl
    Anonymous

    Long Path tool can resolve error messages like: path too long, cannot delete file, too long path, destination path is too long, etc.


Viewing 8 posts - 1 through 8 (of 8 total)

The forum ‘Plugins & Bridges’ is closed to new topics and replies.