Completely deactivate session timeout?

Home Forums Troubleshooting Install & Upgrade Completely deactivate session timeout?

Tagged: , ,

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #42485
    #55368
    Profile photo of Charles
    Charles
    Keymaster

    Hi, what version are yuo currently using? This is doable in the latest (3.3.x) but I think it was not working in 3.2.4. The idea is to set Client Session Timeout to -1 (in Settings > Plugins > Gui Plugins > Gui.ajax )


    Charles, Pydio author - doing my best to help !
    If you like the software or want to say thanks, pay by a tweet, mention #pydio or follow us

    #55373
    Profile photo of abolfazl
    Anonymous

    First, thanks. I’m using 3.2.4 but I can’t find the setting you mentioned. I can’t find the ‘plugins’ you mentioned, only listed:

    logs
    diagnostics
    repositories
    roles
    users
    public files

    nothing else. I’m signed in as admin and I’m using the default installation.
    Thanks!

    edit: do you mean to set “$config[“session_timeout”] = -1;” in the file “class.AJXP_ClientDriver.php”? I try it now…

    edit2: didn’t work, perhaps due to v3.2.4, dunno.
    edit3: Installed latest (3.3.4) and gonna try it with this release now :) (and now I found the settings you mentioned in the GUI without editing the file directly…)


    #55381
    Profile photo of Charles
    Charles
    Keymaster

    try the 3.3.4, the settings WAS NOT in 3.2.4


    Charles, Pydio author - doing my best to help !
    If you like the software or want to say thanks, pay by a tweet, mention #pydio or follow us

    #55387
    Profile photo of abolfazl
    Anonymous

    Okay I tried 3.3.4 now… I entered -1 and it didn’t work. Now I entered 0 (which is the value to deactivate it as I read somewhere on your page or in the docu, dont remember where) -> now I’m immediately logged out when I click on the Gui.ajax settings page… Dunno what happens there :( but I can’t change the value anymore now…


    #55389
    Profile photo of Charles
    Charles
    Keymaster

    are you sure for the -1 ? i was quite sure it was working for me, but i’ll recheck. 0 is making the session last 0 seconds.. To remove the configs modified via the gui, (and reset the installation), remove the file data/plugins/conf.serial/plugins_configs.ser


    Charles, Pydio author - doing my best to help !
    If you like the software or want to say thanks, pay by a tweet, mention #pydio or follow us

    #55400
    Profile photo of abolfazl
    Anonymous

    0 is what there’s mentioned on the options-page. I simply set it to 86400 for now, that’s enough right now to NOT be logged out each 30minutes or so…


    #94331
    Profile photo of abolfazl
    Anonymous

    Charles,

    Does changing this setting also affect iOS/Android app user sessions? I’m currently using version 6.0.8 of Pyd.io and using the VMWare Virtual Appliance. In the information window on this setting it states to set this at “0” to make the session infinite. Wasn’t sure if “0” is the correct setting for version 6.0.8 or if “-1” should be used to make the session(s) infinite. Also curious if this only affects web-based users or all user sessions across any form of access (mobile app, web, etc.).

    If this doesn’t affect mobile users, is there a way to increase the session for them as well?

    We’re having an issue of the server crashing after sessions remain timed out for an extended time it seems.

    Thanks in advance.


    #94339
    Profile photo of abolfazl
    Anonymous

    @charles

    To follow-up, I definitely believe it has something to do with the session timeout on the iOS app. The users’ apps stay logged in all the time and an image/document selection may stay selected for an extended time.

    Roughly 30 minutes after rebooting the server they’re able to use it for another 30 minutes, but then they unable to change images/documents. They’ll receive a timeout error when trying to select another file. Also, they’ll then begin receiving an XML error.

    The web-based portal is unusable at this time as well. But after rebooting, we can successfully browse the database again.

    EDIT:
    I should also mention we have 4 user accounts setup. 1 for each iPad. (Users: kiosk1, kiosk2, kiosk3, kiosk4)
    These users access the same directory and could possibly be accessing the same image/document at the same time.


    • This reply was modified 5 years, 11 months ago by Profile photo of abolfazl .
    #94389
    Profile photo of Charles
    Charles
    Keymaster

    Hi JT
    There’s something strange on your install it seems. A timeout should never trigger a server crash :-)
    Can you PM a temp access to your server?
    -c


    Charles, Pydio author - doing my best to help !
    If you like the software or want to say thanks, pay by a tweet, mention #pydio or follow us

    #94432
    Profile photo of abolfazl
    Anonymous

    @charles

    I apologize for the delayed response. Been battling power outages in our area this past week.

    I’d have to setup routing to make the appliance accessible to traffic outside of its current environment. I’ll look at getting this done and send you the information.

    In the meantime, I enabled guest access to the appliance and now have the iPads accessing the folder with the guest account. They haven’t had the issue since then. It’s not a big issue that they use the guest account as what we’re sharing is available to everyone within our company anyways. We don’t plan on putting confidential information on the appliance.


    #94533
    Profile photo of abolfazl
    Anonymous

    I’m on 6.0.8 and am finding that setting the session timeout to 0 or -1 seems to ignored, and my sessions still time out after 5 minutes.

    I’ve checked my php.ini to see if the session timeout is set there… nope.

    There is some kind of generic error message:

    Unknown Parsing Error!Class.create.displayMessage @ (program):1
    
    

    once the timeout occurs (often right in the middle of playing an MP3), but the logs show only:

    `967
    2015-08-26 20:58:31
    192.168.1.7
    INFO
    austin
    AuthService
    Log Out’


    • This reply was modified 5 years, 11 months ago by Profile photo of abolfazl .
Viewing 12 posts - 1 through 12 (of 12 total)

The forum ‘Install & Upgrade’ is closed to new topics and replies.