No share link after migration and update

IMPORTANT NOTIFICATION - FORUM MOVES TO HTTPS://FORUM.PYDIO.COM

Dear Pydio Community,
This forum will be soon made readonly, as we are transitioning to Discourse. To start on a fresh basis, we decided NOT TO MIGRATE the current threads to the new platform.
As a result, please be kind enough to register there and post your messages at the new location, and if you have an open thread, please do re-open it on Discourse!

Thank you and sorry for the inconvenience
Pydio Team

Home Forums Troubleshooting Install & Upgrade No share link after migration and update

This topic contains 8 replies, has 4 voices, and was last updated by Profile photo of Guy Vanderwalle Guy Vanderwalle 10 months, 1 week ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #107986
    Profile photo of Guy Vanderwalle
    Guy Vanderwalle
    Participant

    Hello,

    best wishes to you all !

    We currently have some problems sharing with the new version of Pydio (7.03)

    First of all, the context:

    We intend to replace our server on which Pydio is installed (6.2)

    As long as we did, we installed version 7.03 on the new server. All user data has been copied (from / home / AJXP_USER to the same tree) and the configuration database also (after having been adapted with the script provided for this purpose)

    After a few adaptations, everything works!

    EXCEPT, and this is important, all sharing links.
    The files of each user are there, but no sharing, nor public link, nor on deposit.

    Do you have an idea of the file and / or folder I forgot to copy?

    Bonjour,

    meilleurs vœux [SPAMMER]!

    Nous avons actuellement quelques problèmes de partages avec la nouvelle version de Pydio (7.03)

    Voici tout d’abord le contexte :

    nous avons l’intention de remplacer notre serveur sur lequel Pydio est installé (6.2)

    Tant qu’à faire, nous avons donc installé sur le nouveau serveur la version 7.03. Toutes les données des utilisateurs ont [SPAMMER]es (de /home/AJXP_USER vers la même arborescence) et la base de donn[SPAMMER]galement (apr[SPAMMER]e avec le script pr[SPAMMER] cet effet)

    Après quelques adaptations, tout fonctionne !

    SAUF, et c’est important, tous les liens de partage.
    Les fichiers de chaque utilisateur sont bien là, mais, pas de partage, ni en lien public, ni en d[SPAMMER]t.

    Avez-vous une idée du fichier et/ou dossier que j’ai oubli[SPAMMER]?

    Bonne journée,

    Guy.


    #107993
    Profile photo of ghecquet
    ghecquet
    Participant

    Bonjour Guy et meilleurs voeux,

    The shares data is kept in the database under the table ajxp_simple_store.

    Did you replace the database entirely or just run the upgrade scripts ?

    What tells you that the shares have disappeared ? Can you not access the public links anymore.. or have the shares information associated to the files or dir disappeared from the UI ?

    Could you run this sql to see if there are shares present in your db ?

    Thanks,

    Bonne journée.
    Greg


    #107995
    Profile photo of ghecquet
    ghecquet
    Participant

    Sorry forgot to paste the script

    select count(*) from ajxp_simple_store where store_id = 'share';

    #107996
    Profile photo of 7omate
    7omate
    Keymaster
    #108000
    Profile photo of Guy Vanderwalle
    Guy Vanderwalle
    Participant

    Hello,
    thanks for your answers.
    effectively, the shares information associated to the files had disappear from the UI.
    The share directories appear in the welcome page, but the share informations are not present near the previously shared files.
    I tried the “select count(*) from ajxp_simple_store where store_id = ‘share’;” on the 2 machines (the first pydio is still on line for the moment and the new one is only accessible inside the network).
    In the first one, the count is 503 and in the new pydio 7.03, the count is 487.
    The copy has been done two weeks ago, and this point can explain the difference.
    On the other hand, i tried the phpmyadmin on the two machine and i can write that, in the first (6.2), the table “ajxp_simple_store” weighs 6,5Mb for 520 lines and in the new one (7.03) the same table weighs 18,3Mb for 520 lines … strange, isn’it ?

    I tried also the make a new shared link on the new pydio, and it’s working perfectly….
    The public link sent me to the right file when i tried to download the shared file.

    I have been looking for several days to solve this problem … can you help me ?


    #108001
    Profile photo of tropicalmango
    tropicalmango
    Participant

    Hello,

    Please try to copy (overwrite) PYDIO_INSTALL_PATH/data/plugins/metastore.serial to same place on new instance
    and please don’t forget to fix permission so that Pydio(apache) can read/write


    #108003
    Profile photo of Guy Vanderwalle
    Guy Vanderwalle
    Participant

    Thanks for your help tropicalmango, indeed, the links are back !
    Very interesting, i leaned something.
    But, unfortunately, an error occured when you follow the link : “Error while parsing JSON response : Unexpected token < in JSON at position 0” in chrome and : “Error while parsing JSON response : JSON.parse: unexpected character at line 1 column 1 of the JSON data” in firefox.
    If i make a new public link, then it’s work.
    We move forward ! But for that error sentence, would anyone have an idea?


    #108012
    Profile photo of 7omate
    7omate
    Keymaster

    If you can, please open the web developer tools and try to locate the actual response.
    My bet is it’s something like :

    Authentication error 
    

    Not sure why it happens.


    #108189
    Profile photo of Guy Vanderwalle
    Guy Vanderwalle
    Participant

    Hello,
    sorry for my late answer. A week of illness.

    I tried the devellopment tools on two links.
    One old link (Pydio 6) and that’s the result :
    http://cloudpydio.lalouviere.be/data/public/a2b9a1.php

    One new link (Pydio 7) and that’s the result :
    http://cloudpydio.lalouviere.be/data/public/058dc0.php

    I don’t understand, i think the old links are not working, but i don’t know why …
    Somebody have an idea ?


Viewing 9 posts - 1 through 9 (of 9 total)

The forum ‘Install & Upgrade’ is closed to new topics and replies.