Problema with Public Link: ldap_control_paged_result_response():

Home Forums Community Problema with Public Link: ldap_control_paged_result_response():

This topic contains 6 replies, has 3 voices, and was last updated by Profile photo of fabiopsk fabiopsk 6 months, 3 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #107913
    Profile photo of fabiopsk
    fabiopsk
    Participant

    Hi,

    I need some help about bellow problem.
    After actualization Pydio to 7.0.3, when I visit some public link always appears the ldap error: “ldap_control_paged_result_response(): Result is: Operations error (1)” . My pydio authentication is on AD and BD.

    It is a big problem with my public links. They cannot be accessed.


    #107952
    Profile photo of 7omate
    7omate
    Keymaster

    If you updated from 6.*.* you probably need to configure a rewrite rule for your old shares.


    #107955
    Profile photo of fabiopsk
    fabiopsk
    Participant

    I believe the rewrite is correct because when I use share with password I don’t receive this message about ldap (ldap_control_paged_result_response():).

    Follow the configuration:

    Rewrite ( / of pydio):
    # cat .htaccess
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule (.*) index.php [L]

    AddType application/json .json

    </IfModule>

    Module:
    # a2enmod rewrite
    Module rewrite already enabled

    My problem is only with public share (without password).


    #107958
    Profile photo of tropicalmango
    tropicalmango
    Participant

    How many users (including ldap users) in Pydio instance ?


    #107962
    Profile photo of fabiopsk
    fabiopsk
    Participant

    We have about 30 users in Pydio (including pydio ldap users).


    #108002
    Profile photo of tropicalmango
    tropicalmango
    Participant

    Hello,

    What is the OS?
    If you are using Ubuntu, there a new update for php-ldap extension.
    Please try to update and test again.


    #108015
    Profile photo of fabiopsk
    fabiopsk
    Participant

    The OS is Debian 8. And php5-ldap in 5.6.29+dfsg-0+deb8u1. And The All Packets are up to date.


Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.