Problems with cache

Home Forums Troubleshooting Generic Help Problems with cache

This topic contains 7 replies, has 3 voices, and was last updated by Profile photo of Tony Cassano bigbroantonio 1 year, 7 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #95882
    Profile photo of Tony Cassano
    bigbroantonio
    Participant

    The title of this topic is a bit vague, but all the problems I’ve been having lead to Pydio not functioning as it should and me having to restore some cache files. I’ll try to explain a little clearer:

    I’ve tried to make a series of adjustments

    1 – Limit the size of the files which can be uploaded by the users (in Application Parameters > Application Core > Uploader Options) by setting the FILE SIZE to 2M (or 2097152 by trying an integer)

    2 – Limit the type of extensions which can be uploaded (by adding some comma-separated extensions to the already present “ser” in Feature Plugins > Workspace Drivers > File System)

    I’ve also tried to change other settings here and there, but when I save, despite getting the green popu telling me that everything is okay, users can’t log in… Specifically, Pydio starts up fine, but all I get in the browser screen are the background image the box telling me that it’s all starting up, but when that disappears I get just the background image, no login box…

    I’ve tried clearing the cache, by deleting the three *.ser files in the /data/cache/ folder, but I still get the same result… The only way to get it up and working again is to revert to the old *.ser files (which I have a backup of…).

    Another thing I’ve noticed is that the site works when the plugins_cache.ser cache file is around 1.3mb (whereas the newly-generated files is 1.4mb).

    Any ideas?

    Another small problem I have is with the Workspace Activity. I would like to be able to clear the activity list (at the moment whenever a file is uploaded by a user, it shows up – which is fine, but sometime I need to clear that log…

    Thanks for your help and sorry for the long post…


    #95883
    Profile photo of 7omate
    7omate
    Keymaster

    Ciao Tony,
    Did you carefully read through this?
    https://pyd.io/knowledge-base-2/f-a-q/#3?70
    Don’t mix up Pydio cache and Browser cache.
    I’m not sure what you’re trying to accomplish with the activity logs, maybe disabling them would work for you?

    Stay tuned for the new version coming soon!
    Best,
    Thomas


    #95886
    Profile photo of Tony Cassano
    bigbroantonio
    Participant

    Ciao Thomas :)

    Thanks for your prompt reply :)

    I’ve already seen the link you posted. I don’t need to raise the upload limit – it’s already set to 25M. I actually wanted to lower the limit to around 2M. I also wanted to prevent certain types of files from being uploaded (like music and video files).

    I’m also aware about browser cache… What I have done is clear the *.ser files from the data/cache folder and then start anew from an “incognito-mode” browser window, which has all its own caches cleared from the start. At that point the cache files are recreated but pydio won’t start up (as I described earlier).

    With reference to the activity logs, I managed to sort it out simply by clearing the ajxp_feed records that I didn’t want to show. BTW, how do I hide the right column (where you see the preview of the files and workspace activity) altogether?

    Thanks :)


    #95893
    Profile photo of 7omate
    7omate
    Keymaster

    https://pyd.io/knowledge-base-2/f-a-q/#3?84
    >UPLOAD : For the upload part, it’s not done via configuration, but you can easily hack one file to suit your needs. Open the file plugins/uploader.flex/flash_tpl.html

    Hiding the right panel would involve messing with the code as well…

    You seem to handle the cache well, maybe something else is going wrong.

    T.


    #95900
    Profile photo of Tony Cassano
    bigbroantonio
    Participant

    Hello again.

    Still having the exact same problems. What worries me most is the fact that I can’t lower the maximum upload limit size. I can’t control this through php.ini because this particular site is running on a shared host which only allows for a few variations of the php.ini settings.

    Basically, whenever I edit any of these settings:

    settings

    the cache *.ser files change size and there is no way for the users to log in…

    Aren’t the same settings supposed to limit which files can be uploaded and which cannot?


    #95902
    Profile photo of Tony Cassano
    bigbroantonio
    Participant

    I was just thinking… could the cache problem have something to do with file/folder permisions? I have everything set to chmod 0755…


    #95930
    Profile photo of Charles
    Charles
    Keymaster

    Hi Bigbroantonio, what kind of backend do you use for configurations storage? MySQL or something else?
    -c


    Charles, Pydio author - doing my best to help !
    If you like the software or want to say thanks, pay by a tweet, mention #pydio or follow us

    #95947
    Profile photo of Tony Cassano
    bigbroantonio
    Participant

    Hi Charles. I’m using MySQL.


Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.