Repository: unable to find expected entry Packages in Release file

Home Forums Troubleshooting Install & Upgrade Repository: unable to find expected entry Packages in Release file

This topic contains 16 replies, has 8 voices, and was last updated by Profile photo of laurent_joli laurent_joli 6 months, 1 week ago.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #93838
    Profile photo of Unknownflag
    Unknownflag
    Participant

    Hi all,

    I’m new to Pydio, but i’m encountering issues already to download from the official repository of Pydio:

    I’ve added the two repositories of Debian-based versions of Pydio to /etc/apt/sources.list, but when i do an apt-get update it gives me that:

    “Failed to fetch http://dl.ajaxexplorer.info/repos/apt/dists/stable/Release Unable to find expected entry ‘main/binary-armhf/Packages’ in Release file”

    Are there any problems on the repository?


    #93856
    Profile photo of Charles
    Charles
    Keymaster

    Hi,
    There was a network issue with this server during the day, did you retry since then?
    -c


    Charles, Pydio author - doing my best to help !
    If you like the software or want to say thanks, pay by a tweet, mention #pydio or follow us

    #94497
    Profile photo of Denny
    Denny
    Participant

    I have the same issue. I run a debian jessy on a cubiboard2.

    – add deb lines to sources.list
    – apt-get update

    W: Failed to fetch http…/InRelease Unable to find expected entry ‘main/binary-armhf/Packages’ in Release file (Wrong sources.list entry or malformed file)

    But, its possible to wget the file direct. I can download the InRelease file trouble-free.


    #94523
    Profile photo of Charles
    Charles
    Keymaster

    @c12simple can you test a clean install on a debian? do we have an issue in the repository?


    Charles, Pydio author - doing my best to help !
    If you like the software or want to say thanks, pay by a tweet, mention #pydio or follow us

    #94528
    Profile photo of Denny
    Denny
    Participant

    “InRelease” contains no section with “arm”. No support for ARM devices?


    #94609
    Profile photo of Charles
    Charles
    Keymaster

    Ha it’s the ARM section missing, yes probably. We will rework our packaging deeply, so stay tuned.


    Charles, Pydio author - doing my best to help !
    If you like the software or want to say thanks, pay by a tweet, mention #pydio or follow us

    #95179
    Profile photo of Calvin vin
    Calvinn6
    Participant

    Hello,
    I´ve the pydio in Raspberry.
    The actual version is 6.0.6…The system give me a message to update to 6.0.7 and 6.0.8.
    If I update from the web…I have the next problem:
    “Your installation is managed directly via os packages, you should not upgrade manually.”

    then…I try Update from console:
    sudo nano /etc/apt/sources.list
    deb http://dl.ajaxplorer.info/repos/apt stable main
    deb-src http://dl.ajaxplorer.info/repos/apt stable main
    sudo apt-get update

    And this momento….This is the problem:
    W: Failed to fetch http://dl.ajaxplorer.info/repos/apt/dists/stable/InRelease Unable to find expected entry ‘main/binary-armhf/Packages’ in Release file (Wrong sources.list entry or malformed file)

    What is the problem?

    thx!!!!!!


    #95216
    Profile photo of Calvin vin
    Calvinn6
    Participant

    Hi!
    Anybody help me??


    #95217
    Profile photo of Denny
    Denny
    Participant

    Raspberry PI, Cubiboard = ARM -> no ARM support via the sources

    @charles: Is a solution in sight?


    #95218
    Profile photo of Calvin vin
    Calvinn6
    Participant

    Raspberry PI, Cubiboard = ARM -> no ARM support via the sources

    Ok, then….how I update the pydio?

    Thx!


    #95219
    Profile photo of Denny
    Denny
    Participant
    #95264
    Profile photo of Charles
    Charles
    Keymaster

    Guys
    We we are working on reworking entirely our build machines and packaging output, so we’ll make sure to add the ARM support in the definition. This should be in a month from now, worst case.
    -c


    Charles, Pydio author - doing my best to help !
    If you like the software or want to say thanks, pay by a tweet, mention #pydio or follow us

    #99084
    Profile photo of Aeon512
    Aeon512
    Participant

    Hey Charles,
    any updates on this? I just followed the guidelines on adding the repository, but it still fails with no armhf packages being available…

    /Aeon512


    #100431
    Profile photo of CVBruce
    CVBruce
    Participant

    Did this ever get resolved? I’m still getting the same error, I think.

    W: Failed to fetch https://download.pydio.com/pub/linux/debian/dists/jessie-backports/InRelease Unable to find expected entry ‘main/binary-armhf/Packages’ in Release file (Wrong sources.list entry or malformed file)

    W: Failed to fetch https://download.pydio.com/auth/linux/debian/dists/jessie-backports/InRelease Unable to find expected entry ‘main/binary-armhf/Packages’ in Release file (Wrong sources.list entry or malformed file)

    Thanks,

    CVBruce


    #107195
    Profile photo of Rustem
    Rustem
    Participant

    Hi
    Same problem here. Any update on the issue with arm support? Would be nice to have any suggestions or any help to resolve the problem (Raspberry Pi 3, Raspbian based on Jessie, Pydio 6.0.8).
    Thank you!


Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.